Name:Lumix Copier
 
Version:1.3.2.8
 
Publisher:Hamar Data
 
The following prerequisites are required:
 
  • .NET Framework 3.5
  • Windows Installer 3.1
If these components are already installed, you can launch the application now. Otherwise, click the button below to install the prerequisites and run the application.
 
Install
 
Hamar Data Customer Support    ::    ClickOnce and .NET Framework Resources